# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|\\"(?!\\/))(?>[^"]|(?<!\\)")*?\K\bJohn\b/Joe/gs;t' <<< "John \\"John, Hello there John! \\"/ John looks back. \\"John, oh John! \\"/ Not this John"