using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\\""(?!\/))(?>[^""]|(?<!\\)"")*?\K\bJohn\b";
string substitution = @"Joe";
string input = @"John \""John, Hello there John! \""/ John looks back. \""John, oh John! \""/ Not this John";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}