const regex = /(?:\G(?!\A)|\\"(?!\/))(?>[^"]|(?<!\\)")*?\K\bJohn\b/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|\\\\"(?!\\\/))(?>[^"]|(?<!\\\\)")*?\\K\\bJohn\\b', 'gs')
const str = `John \\"John, Hello there John! \\"/ John looks back. \\"John, oh John! \\"/ Not this John`;
const subst = `Joe`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);