import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<\\!\\-\\-.*?\\-\\-\\>";
final String string = "<!--asdasdasd-->\n"
+ "<div>\n"
+ " <span>This is a text</span>\n\n"
+ " <!--\n"
+ " \n"
+ " asdasd\n"
+ " \n"
+ " asdlkasd jlaksd a\n"
+ " -->\n"
+ " <div>\n"
+ " <span>This is a text</span>\n"
+ " <div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}