re = /\<\!\-\-.*?\-\-\>/m
str = '<!--asdasdasd-->
<div>
<span>This is a text</span>
<!--
asdasd
asdlkasd jlaksd a
-->
<div>
<span>This is a text</span>
<div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end