$re = '/\<\!\-\-.*?\-\-\>/m';
$str = '<!--asdasdasd-->
<div>
<span>This is a text</span>
<!--
asdasd
asdlkasd jlaksd a
-->
<div>
<span>This is a text</span>
<div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);