#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\. Blabla[\S\s]*?(?=^\d+\. )"
Local $sString = "1. Notice " & @CRLF & _
"Some text " & @CRLF & _
"End Notice" & @CRLF & _
"2. Blabla " & @CRLF & _
"Some other text " & @CRLF & _
"Even more text" & @CRLF & _
"3. Notice " & @CRLF & _
"Some more text" & @CRLF & _
"End Notice" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")