import re
regex = re.compile(r"\d+\. Blabla[\S\s]*?(?=^\d+\. )", flags=re.MULTILINE)
test_str = ("1. Notice \n"
"Some text \n"
"End Notice\n"
"2. Blabla \n"
"Some other text \n"
"Even more text\n"
"3. Notice \n"
"Some more text\n"
"End Notice\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")