re = /\d+\. Blabla[\S\s]*?(?=^\d+\. )/m
str = '1. Notice
Some text
End Notice
2. Blabla
Some other text
Even more text
3. Notice
Some more text
End Notice
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end