package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{4}`)
var str = `9862 ....... -pack size 1 - SST Unspun Label (Roll) CAT#: 9862`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}