$re = '/\d{4}/m';
$str = '9862 ....... -pack size 1 - SST Unspun Label (Roll) CAT#: 9862';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);