re = /\d{4}/m
str = '9862 ....... -pack size 1 - SST Unspun Label (Roll) CAT#: 9862'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end