import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\b([a-zA-Z]+\\s[a-zA-Z]+)\\b.*";
final String string = "50 - David Herd (1961-1968)\n"
+ "49 - Teddy Sheringham (1997-2001)\n"
+ "48 - George Wall (1906-1915)\n"
+ "47 - Stan Pearson (1935-1954)\n"
+ "46 - Harry Gregg (1957-1966)\n"
+ "45 - Paddy Crerand (1963-1971)\n"
+ "44 - Jaap Stam (1998-2001)\n"
+ "43 - Paul Ince (1989-1995)\n"
+ "42 - Dwight Yorke (1998-2002)";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}