# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?\b([a-zA-Z]+\s[a-zA-Z]+)\b.*"
test_str = ("50 - David Herd (1961-1968)\n"
"49 - Teddy Sheringham (1997-2001)\n"
"48 - George Wall (1906-1915)\n"
"47 - Stan Pearson (1935-1954)\n"
"46 - Harry Gregg (1957-1966)\n"
"45 - Paddy Crerand (1963-1971)\n"
"44 - Jaap Stam (1998-2001)\n"
"43 - Paul Ince (1989-1995)\n"
"42 - Dwight Yorke (1998-2002)")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.