const regex = /^.*?\b([a-zA-Z]+\s[a-zA-Z]+)\b.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\b([a-zA-Z]+\\s[a-zA-Z]+)\\b.*', 'gm')
const str = `50 - David Herd (1961-1968)
49 - Teddy Sheringham (1997-2001)
48 - George Wall (1906-1915)
47 - Stan Pearson (1935-1954)
46 - Harry Gregg (1957-1966)
45 - Paddy Crerand (1963-1971)
44 - Jaap Stam (1998-2001)
43 - Paul Ince (1989-1995)
42 - Dwight Yorke (1998-2002)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);