using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\s\b(href|title)\b.*\"">)?|(<[\/]a>)";
string input = @"<a href=\\\""http://www.dfs.ny.gov/\\\"">www.dfs.ny.gov</a>, for free information on comparative credit card rates, fees and grace periods. </span>"";
<a id=\""OLE_LINK2\"" class=\""bookmark\"" title=\""OLE_LINK2\"" name=\""OLE_LINK2\""></a>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}