use strict;
my $str = '<a href=\\\\\\"http://www.dfs.ny.gov/\\\\\\">www.dfs.ny.gov</a>, for free information on comparative credit card rates, fees and grace periods. </span>";
<a id=\\"OLE_LINK2\\" class=\\"bookmark\\" title=\\"OLE_LINK2\\" name=\\"OLE_LINK2\\"></a>
';
my $regex = qr/(<a\s\b(href|title)\b.*\">)?|(<[\/]a>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}