re = /(<a\s\b(href|title)\b.*\">)?|(<[\/]a>)/
str = '<a href=\\\\\\"http://www.dfs.ny.gov/\\\\\\">www.dfs.ny.gov</a>, for free information on comparative credit card rates, fees and grace periods. </span>";
<a id=\\"OLE_LINK2\\" class=\\"bookmark\\" title=\\"OLE_LINK2\\" name=\\"OLE_LINK2\\"></a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end