#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$status(?:\[[^\]]+\])?[^'"]*(?:'\K(?:[^']|'')+|"\K[^"]+)"
Local $sString = "$status['Совершенно_новое'] = 'Brand_new<<'' New''>>New' " & @CRLF & _
"$status['Совершенно_новое'] = 'Brand_new<br>New'" & @CRLF & _
"$status['2'] = "Brand_new<<' New'>>New" " & @CRLF & _
"$status["3"] = "Brand_new<<' New'>>New" " & @CRLF & _
"$status[4] = "Brand_new<<' New'>>New" " & @CRLF & _
"$status[''8''] = "Brand_new<<' New'>>New" " & @CRLF & _
"$status['5'] = 'Brand_new""<<' New'>>New' " & @CRLF & _
"$status = 'Brand_new<<'' New''>>New' " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")