using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$status(?:\[[^\]]+\])?[^'""]*(?:'\K(?:[^']|'')+|""\K[^""]+)";
string input = @"$status['Совершенно_новое'] = 'Brand_new<<'' New''>>New'
$status['Совершенно_новое'] = 'Brand_new<br>New'
$status['2'] = ""Brand_new<<' New'>>New""
$status[""3""] = ""Brand_new<<' New'>>New""
$status[4] = ""Brand_new<<' New'>>New""
$status[''8''] = ""Brand_new<<' New'>>New""
$status['5'] = 'Brand_new""<<' New'>>New'
$status = 'Brand_new<<'' New''>>New'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}