use strict;
my $str = 'fprintf(out, os.str().c_str());';
my $regex = qr/(fprintf(\s*)\((\s*\S+)[,])([^\"])/mp;
my $subst = '\\1 "%s",';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";