re = /(fprintf(\s*)\((\s*\S+)[,])([^\"])/m
str = 'fprintf(out, os.str().c_str());'
subst = '\\1 "%s",'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result