import Foundation
let pattern = #"(fprintf(\s*)\((\s*\S+)[,])([^\"])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"fprintf(out, os.str().c_str());"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 "%s","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)