using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\_{4}[\r\n]([\s\S]+?(?=^\_{4}[\r\n]))\_{4}[\r\n]";
string input = @"
____
____
____
fff
____
____
df123 dsfds
ggdg fsdf
____
_____
dfdsfds
gfsdf
_____
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}