re = /^\_{4}[\r\n]([\s\S]+?(?=^\_{4}[\r\n]))\_{4}[\r\n]/m
str = '
____
____
____
fff
____
____
df123 dsfds
ggdg fsdf
____
_____
dfdsfds
gfsdf
_____
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end