const regex = /^\_{4}[\r\n]([\s\S]+?(?=^\_{4}[\r\n]))\_{4}[\r\n]/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\_{4}[\\r\\n]([\\s\\S]+?(?=^\\_{4}[\\r\\n]))\\_{4}[\\r\\n]', 'mg')
const str = `
____
____
____
fff
____
____
df123 dsfds
ggdg fsdf
____
_____
dfdsfds
gfsdf
_____
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}