package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:badword|curseword|ass)\b`)
var str = `This is the text that contains a badword
The grass is grean`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}