re = /\b(?:badword|curseword|ass)\b/m
str = 'This is the text that contains a badword
The grass is grean'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end