$re = '/\b(?:badword|curseword|ass)\b/m';
$str = 'This is the text that contains a badword
The grass is grean';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);