#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)COMPANY DETAILS\s+Date\s*:.*\s*(.+)"
Local $sString = "COMPANY DETAILS" & @CRLF & _
"" & @CRLF & _
"Date : 01-06-2018" & @CRLF & _
"" & @CRLF & _
"ABC Industries" & @CRLF & _
"12-31 Lane" & @CRLF & _
"New York" & @CRLF & _
"" & @CRLF & _
"Contact No. 1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")