$re = '/COMPANY DETAILS\s+Date\s*:.*\s*(.+)/m';
$str = 'COMPANY DETAILS
Date : 01-06-2018
ABC Industries
12-31 Lane
New York
Contact No. 1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);