re = /COMPANY DETAILS\s+Date\s*:.*\s*(.+)/m
str = 'COMPANY DETAILS
Date : 01-06-2018
ABC Industries
12-31 Lane
New York
Contact No. 1111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end