using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Attn |^C\/- |^C\/O ";
string input = @"Bond, James Bond
Attn Miss Moneypenny
C/- Mr Bill Tanner
C/O Ms Mary Goodnight";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}