re = /^Attn |^C\/- |^C\/O /m
str = 'Bond, James Bond
Attn Miss Moneypenny
C/- Mr Bill Tanner
C/O Ms Mary Goodnight'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end