$re = '/^Attn |^C\/- |^C\/O /m';
$str = 'Bond, James Bond
Attn Miss Moneypenny
C/- Mr Bill Tanner
C/O Ms Mary Goodnight';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);