#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^i]|i[^n]|in[^s]|ins[^t]|inst[^a]|insta[^g]|instag[^r]|instagr[^a]|instagra[^m]|instagram[^.]).{1,30}\.fbcdn\.net$"
Local $sString = "instagram.fsst1-2.fna.fbcdn.net" & @CRLF & _
"instagram.acd.yc.fbcdn.net" & @CRLF & _
"instagram.xffuyw-34.hj.fbcdn.net" & @CRLF & _
"instagra.xffuyw-34.hj.fbcdn.net" & @CRLF & _
"inst.xffuyw-34.hj.fbcdn.net" & @CRLF & _
"static.xx.fbcdn.net" & @CRLF & _
"dyna.yudhn.fbcdn.net" & @CRLF & _
"asq.iud.fbcdn.net" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")