package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^i]|i[^n]|in[^s]|ins[^t]|inst[^a]|insta[^g]|instag[^r]|instagr[^a]|instagra[^m]|instagram[^.]).{1,30}\.fbcdn\.net$`)
var str = `instagram.fsst1-2.fna.fbcdn.net
instagram.acd.yc.fbcdn.net
instagram.xffuyw-34.hj.fbcdn.net
instagra.xffuyw-34.hj.fbcdn.net
inst.xffuyw-34.hj.fbcdn.net
static.xx.fbcdn.net
dyna.yudhn.fbcdn.net
asq.iud.fbcdn.net
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}