using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^i]|i[^n]|in[^s]|ins[^t]|inst[^a]|insta[^g]|instag[^r]|instagr[^a]|instagra[^m]|instagram[^.]).{1,30}\.fbcdn\.net$";
string input = @"instagram.fsst1-2.fna.fbcdn.net
instagram.acd.yc.fbcdn.net
instagram.xffuyw-34.hj.fbcdn.net
instagra.xffuyw-34.hj.fbcdn.net
inst.xffuyw-34.hj.fbcdn.net
static.xx.fbcdn.net
dyna.yudhn.fbcdn.net
asq.iud.fbcdn.net
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}