re = /^\S+(?:\s+\S+){2}\K\s+/
str = 'Some example here for you'
subst = ',$0'
result = str.sub(re, subst)
# Print the result of the substitution
puts result