# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*([\x{0080}-\x{02AF}]|\d.*[a-zA-Z]|[a-zA-Z].*\d).*|^[a-zA-Z]+$"
test_str = ("融360\n"
"הבנק הבינלאומי\n"
"АТ \"Акцент-Банк\n"
"АО АЛСЕКО\n"
"АО \"Altyn Bank\"\n"
"АКБ \"Kapitalbank\n"
"Şekerbank\n"
"İninal\n"
"Československá obchodní banka\n"
"iBillionaire\n"
"iBear\n"
"iBankマーケティング株式会社\n"
"4finance\n"
"11번가(주)\n"
"11com7 design\n"
"1 2 3 Apps\n"
"1 2 3 Apps\n"
"(주)인포바인")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.