using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"P(\d{1,}.\d{1,}) (?<=)of(?= to)";
string input = @"You have paid P85.00 of GCash to Total NLEX Bonjour on 12-30-19 05:51:47 PM. Ref. No. 914311523.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}