use strict;
my $str = 'You have paid P85.00 of GCash to Total NLEX Bonjour on 12-30-19 05:51:47 PM. Ref. No. 914311523.';
my $regex = qr/P(\d{1,}.\d{1,}) (?<=)of(?= to)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}