#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^DATE:.*((?:\n(?!AREA:).*)+)"
Local $sString = "AREA: OMBEYI MARKET, ST. RITA RAMULA" & @CRLF & _
"" & @CRLF & _
"DATE: Thursday 25.03.2021, TIME: 9.00 A.M. = 5.00 P.M." & @CRLF & _
"" & @CRLF & _
"Ombeyi Mk, Kiliti Mkt, Masogo Mkt, Miwani, Kasongo, Onyango Midika, St. Rita Ramula, Onyalo" & @CRLF & _
"Biro, Yawo Pri, Obino, Rutek, Keyo Pri & adjacent customers." & @CRLF & _
"" & @CRLF & _
"AREA: NYAMACHE FACTORY" & @CRLF & _
"" & @CRLF & _
"DATE: Thursday 25.03.2021, TIME: 830 A.M. - 3.00 P.M." & @CRLF & _
"" & @CRLF & _
"Nyamache Fact, Suguta, Gionseri, Igare, Kionduso, Nyationgongo, Enchoro, Kebuko, Emenwa, Maji" & @CRLF & _
"Mazuri, Borangi & adjacent customers." & @CRLF & _
"" & @CRLF & _
"AREA: SUNEKA MARKET, RIANA MARKET" & @CRLF & _
"" & @CRLF & _
"DATE: Thursday 25.03.2021, TIME: 8.00 A.M. - 3.00 P.M." & @CRLF & _
"" & @CRLF & _
"Suneka Mk, Riana Mk, Kiabusura, Gesonso, Chisaro, Sugunana, Nyamira Ndogo & adjacent" & @CRLF & _
"customers." & @CRLF & _
"" & @CRLF & _
"AREA: ITIATI, GITUNDUTI" & @CRLF & _
"" & @CRLF & _
"DATE: Thursday 25.03.2021, TIME: 9.00 A.M. = 2.00 P.M." & @CRLF & _
"" & @CRLF & _
"General China, Gachuiro, Gathuini Pri, Itiati Campus, Kianjugum, Gikore, Kihuri TBC, Gitunduti &" & @CRLF & _
"adjacent customers."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")