import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^DATE:.*((?:\\n(?!AREA:).*)+)";
final String string = "AREA: OMBEYI MARKET, ST. RITA RAMULA\n\n"
+ "DATE: Thursday 25.03.2021, TIME: 9.00 A.M. = 5.00 P.M.\n\n"
+ "Ombeyi Mk, Kiliti Mkt, Masogo Mkt, Miwani, Kasongo, Onyango Midika, St. Rita Ramula, Onyalo\n"
+ "Biro, Yawo Pri, Obino, Rutek, Keyo Pri & adjacent customers.\n\n"
+ "AREA: NYAMACHE FACTORY\n\n"
+ "DATE: Thursday 25.03.2021, TIME: 830 A.M. - 3.00 P.M.\n\n"
+ "Nyamache Fact, Suguta, Gionseri, Igare, Kionduso, Nyationgongo, Enchoro, Kebuko, Emenwa, Maji\n"
+ "Mazuri, Borangi & adjacent customers.\n\n"
+ "AREA: SUNEKA MARKET, RIANA MARKET\n\n"
+ "DATE: Thursday 25.03.2021, TIME: 8.00 A.M. - 3.00 P.M.\n\n"
+ "Suneka Mk, Riana Mk, Kiabusura, Gesonso, Chisaro, Sugunana, Nyamira Ndogo & adjacent\n"
+ "customers.\n\n"
+ "AREA: ITIATI, GITUNDUTI\n\n"
+ "DATE: Thursday 25.03.2021, TIME: 9.00 A.M. = 2.00 P.M.\n\n"
+ "General China, Gachuiro, Gathuini Pri, Itiati Campus, Kianjugum, Gikore, Kihuri TBC, Gitunduti &\n"
+ "adjacent customers.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}