import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z0-9\\xf6\\xd6\\xc7\\xe7\\u015e\\u015f\\u011e\\u011f\\u0130\\u0131\\xdc\\xfc_]";
final String string = "öÖÇ窺ĞğİıÜüş or ğ it is";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}