import Foundation
let pattern = #"[A-Za-z0-9\xf6\xd6\xc7\xe7\u015e\u015f\u011e\u011f\u0130\u0131\xdc\xfc_]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"öÖÇ窺ĞğİıÜüş or ğ it is"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)