$re = '/object\/(?:custom|standard)\/(.*?(?=\/type[ab]|$))(?:\/(type[ab])(?:\/(.*))?)?/m';
$str = 'Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept
object/custom/name1/name2
object/custom/name1/name2/typea
object/custom/name1/name2/typea/item';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);