re = /object\/(?:custom|standard)\/(.*?(?=\/type[ab]|$))(?:\/(type[ab])(?:\/(.*))?)?/m
str = 'Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept
object/custom/name1/name2
object/custom/name1/name2/typea
object/custom/name1/name2/typea/item'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end