package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)echo: (?<sound>\S+)(?:(?<lostAndNoise>.+)(?<echo>\k<sound>))+`)
var str = `echo: yahoo yaha yaho ah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}