$re = '/echo: (?<sound>\S+)(?:(?<lostAndNoise>.+)(?<echo>\k<sound>))+/mu';
$str = 'echo: yahoo yaha yaho ah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);